'Checking device error' message on ToneLib Zoom tool

Discussion in 'Bug Reports' started by R Jacobo, Aug 25, 2019.

  1. R Jacobo

    R Jacobo New Member

    Please, need help.

    I'm having some trouble with the app. Sometimes I'm receiving an error message in the tool:

    Checking Device Error
    Unable to get an identity response from the "Check"

    I have to close and try again.

    On another occasions, I do not receive any error message but I'm unable to use the tool. I can see the patches, effects chain section and device effects but the tool freezes and, if I click anywhere in the tool, it gets a grey layer over it. I think that means the tool already crashed. I can only close it.

    I'm connecting a G1Xon pedal and already verified the firmware version is 1.21.
    ToneLib Zoom app version is 3.8.5
    My PC: Windows 10 Pro, 32 bit

    This is the error message:

    The grey layer:
    Never been able to use the tool.
    RoryMon likes this.
  2. MrEdward

    MrEdward New Member

    Hey, just had the same issue with a brand new MS70cdr; in my case a another application was actually connected to the pedal and was using the midi port used by the Tonelib to communicate with the pedal (actually it was this https://g200kg.github.io/zoom-ms-utility/)
    Once closed everything worked like a charm...
  3. Scanner

    Scanner New Member


    I also encounter this problem. I blocked MIDI-access for zoom-ms-utility but this didn't solve the "Checking device error".

    Tonelib Zoom is not able to connect with the MS-70CDR.

    Can you please help me out?

  4. Marios101

    Marios101 New Member

    Same error for me, the USB works to power on my B1 Four, but is unable to connect to Tonelib, with the error message posted above. Some Windows upgrade maybe?
  5. Scanner

    Scanner New Member

    Yes, could be Windows. My other editor, Zoom MSUtility, does not have any problem connecting. I also checked if any process is keeping the MS-70CDR busy but this was not the case. For the moment I'm out of troubleshooting ideas. Hope someone else can find a solution.
  6. KevinL7778

    KevinL7778 New Member

    I have seen this also, closing windows wave midi or what ever the windows default for midi is fixed the error.
  7. Scanner

    Scanner New Member

    Hi Kevin, I tried closing Microsoft GS Wavetable Synth but it did not bring the solution. The default Windows midi output is no longer available in the Windows Settings. I installed CoolSoft MIDIMapper to be able to set the preferred Midi Output. Also switching to different outputs did not work.

  8. KevinL7778

    KevinL7778 New Member

    you should be able to do it with no helper apps, try a pc restart and plug it in and launce zoom, if another pp is blocking the zoom app from getting a device id it will probaply fail the "device check" but this is opinion.
  9. mobass

    mobass New Member

    I'm encountering the same error on Windows 10. Restarting the PC and trying again had no effect. Zoom Guitar Lab v7.3 seems to hang at Device Found, Loading.

    Device: Zoom B1X Four
    ToneLib-Zoom version 4.3.1 free

    FWIW: When I tried plugging the B1X Four into a different USB port, Windows 10 presented a notification about a device being set up. On the Bluetooth & Other Devices settings page, I see Zoom G Series as an audio device connected to USB 3.0. Still get the same error. Tried removing the device via the settings page and trying again to no effect
  10. KevinL7778

    KevinL7778 New Member

    If you can try the mobile app try that, there could be an issue with your device but if you can get it to work correctly on a moble then its not the device.
  11. Scanner

    Scanner New Member

    I tried everything (again).

    Removing the MS-70CDR from devices, restarting PC so the device had to reinstall the drivers when connecting. Not able to connect ToneLib-Zoom.

    Tried one more time starting ToneLib-Zoom before reconnecting the MS-70CDR. Not able to connect.

    Checked if any app is occupying the Zoom, nothing found.

    My PC with Windows 10 is very clean and tidy. All the gear in my studio is working without any problem. Only ToneLib-Zoom is giving me a headache ;-).

    Thanks for the tips but again I do not have a clue how to solve this Checking Device Error.

    Have a nice weekend!
  12. Tournesol

    Tournesol New Member

    Same problem for me... and no solution found.
    At least, you're note alone...
  13. mobass

    mobass New Member

    I don't have a cable to connect to a mobile device.
    I installed Tonelib-Zoom on a Windows 10 laptop and the Zoom B1X Four was recognized without issue.
    Back on the original desktop, I tried uninstalling Tonelib Zoom and reinstalling. Unfortunately, I'm still getting the "unable to get an identity response" error.
  14. Scanner

    Scanner New Member

    Good to know I am not the only one...
  15. Tournesol

    Tournesol New Member

    By the way...
    I tried another USB cable : same result, same problem...
  16. Tournesol

    Tournesol New Member

    Something new today : the error message changed ! Now it says :
    Checking device error
    Unable to open "Check" for reading

    I asked Tonelib (with the "contact us" button at the bottom of the page).
    No answer yet.
  17. Scanner

    Scanner New Member

    I'm waiting for an answer from Tonelib for 4 weeks now. And tried a different USB-cable. Nothing....
  18. Scanner

    Scanner New Member

    I don't know what happened or changed but I am able to open ToneLib Zoom and connect with my MS-70CDR again! Hopefully it's not a one time lucky shot.
  19. Tournesol

    Tournesol New Member

    You're lucky !
    I'm still unable to use it with my B1on and G1on...
  20. mobass

    mobass New Member

    I also don't know what happened or changed and hoping it's not a one-day lucky shot. ToneLib Zoom connects to my B1X Four again on my desktop. It's also still working on the laptop I tried.