GFX 4.6.5 Linux install error

Discussion in 'Bug Reports' started by tonelibwlk, Apr 17, 2021.

  1. tonelibwlk

    tonelibwlk Member

    Hi, just tried to install GFX 4.6.5 on Ubuntu 20.04, and got the following error on attempting to install:

    me@Machine:~/Downloads$ sudo apt install ./ToneLib-GFX-amd64.deb
    Reading package lists... Done
    Building dependency tree
    Reading state information... Done
    Note, selecting 'tonelib-gfx' instead of './ToneLib-GFX-amd64.deb'
    The following package was automatically installed and is no longer required:
    Use 'sudo apt autoremove' to remove it.
    The following packages will be upgraded:
    1 upgraded, 0 newly installed, 0 to remove and 6 not upgraded.
    Need to get 0 B/40.5 MB of archives.
    After this operation, 0 B of additional disk space will be used.
    Get:1 /home/me/Downloads/ToneLib-GFX-amd64.deb tonelib-gfx amd64 4.6-5 [40.5 MB]
    (Reading database ... 504834 files and directories currently installed.)
    Preparing to unpack .../ToneLib-GFX-amd64.deb ...
    Unpacking tonelib-gfx (4.6-5) over (4.6-4) ...
    dpkg-deb (subprocess): decompressing archive member: lzma error: compressed data is corrupt
    dpkg-deb: error: <decompress> subprocess returned error exit status 2
    dpkg: error processing archive /home/me/Downloads/ToneLib-GFX-amd64.deb (--unpack):
    cannot copy extracted data for './usr/bin/ToneLib-GFX' to '/usr/bin/ToneLib-GFX.dpkg-new': unexpected end of file or stream
    Errors were encountered while processing:
    E: Sub-process /usr/bin/dpkg returned an error code (1)

  2. Admin

    Admin Administrator Staff Member

    Hi, thank you for pointing this out! It should be fixed now, please redownload and try again.
  3. tonelibwlk

    tonelibwlk Member

    Yes, that works now, thanks!