Jam 4.3.3 crash trying to access main menu

Discussion in 'Bug Reports' started by Andriy, Mar 1, 2020.

  1. Andriy

    Andriy New Member

    Hello guys,
    first of all, let me say one big thank you for all of your efforts to make music software work on linux.

    I'm in process of evaluating TL GFX and Jam products on OpenSUSE linux and faced an issue trying to access main menu in Jam. Whenever I try to open any of main menu options with mouse, Jam crashes showing 'Critical error in application' dialog. I've mailed a report it generates.
    I've reproduced it under gdb:
    and generated coredump file. It size ~1.2GB uncompressed, and ~54MB when compressed with 7z. Please let me know where to upload it should you need it.
    Looks like an issue, which was fixed recently, and described here: https://tonelib.net/forums/threads/tonelib-jam-3-9-9-crashing-on-linux.5975/
    But that issue was fixed, and version of Jam I'm using is 4.3.4 (current at the moment).
    I'm using OpenSUSE Leap 15.0 x86_64, nothing special.
    Could you, please, give some advise on how to resolve or overcome this issue. Any additional information - on your request.

    There are a couple more issues which are not so significant, but if you please:

    1. After mentioned crash, trying to start Jam results in absence of main window, only Quick Start dialog is visible for some seconds, after that Jam closes completely. There is message in console related to this case:
    After some runs, this issue disappears - Jam starts normally.

    2. During mentioned crash, if I agree to send an error report, it doesn't actually send it, instead I see in console:
    So, I've decoded that message and sent it manually.

    I will be glad if this information will help to make the products more reliable.

    P.S. Updated my initial post a bit.
    Last edited: Mar 5, 2020
  2. Charlespalding

    Charlespalding New Member

    I got the same problem in UBUNTU 18.04
  3. Andriy

    Andriy New Member

    Got the same issue (#1) with OpenSUSE Tumbleweed x86_64.
  4. zavorra

    zavorra New Member

    same on Ubuntu 19.10

    I hope they will start distributing this (otherwise great) SW as a snap/flatpak/appimage and get rid of the dependency nightmare
    Last edited: Apr 16, 2020
  5. tms

    tms New Member

    I'm on ubuntu 18.04 as well and experienced the same problems. I managed at least to get Jam running under wine.

    What I did:

    1) update to the latest stable wine version

    My local wine installation was 3.x, this is pretty outdated. I don't know if updating the wine installation is necessary to get Jam running but I decided to go for it nonetheless.

    You have to use some external repositories to get the latest packages. Here is an excellent German tutorial: https://wiki.ubuntuusers.de/Wine/.

    My command list:

    sudo apt remove wine-stable
    sudo apt-key adv --keyserver keyserver.ubuntu.com --recv-keys DFA175A75104960E
    sudo apt-add-repository 'deb https://download.opensuse.org/repositories/Emulators:/Wine:/Debian/xUbuntu_18.04/ ./'
    sudo dpkg --add-architecture i386 # Only required for 64-Bit-Systems
    wget -O - https://dl.winehq.org/wine-builds/winehq.key | sudo apt-key add -
    sudo add-apt-repository 'https://dl.winehq.org/wine-builds/ubuntu/' && sudo apt update
    sudo apt install winehq-stable

    My local wine installation was updated from version 3.x to 5.0 (wine --version). Commands were taken from the site mentioned above. Use at your own risk and only if you know what you are doing!

    2) Installing the msi Jam file

    Make sure to have the package msitools installed.

    3) Setting windows version for Jam to Windows 2008

    Launch winecfg and choose the tab "Applications" or something similar and add a new Windows version for the Jam exe file. I tried 10, 8, 7 and 2008 but only 2008 worked for me.

    That's it! Jam starts nicely, loading and playing songs works perfectly only the 3D view mode does not initialize, I think I'm missing some Direct X stuff here, but editor view suits me quite well.

    So I hope this might help. However a fix for the native linux version would be highly appreciated :)

    I never used Jam before and was too curious to wait for the Linux fix. My first impressions are great! Seems to be an amazing software. Keep up the good work!

    startdias likes this.