ToneLib GFX crashes inside Ardour

Discussion in 'Bug Reports' started by Elson Fernandes, Apr 25, 2021.

  1. Elson Fernandes

    Elson Fernandes New Member

    Hi,
    I always use the ToneLib GFX to record my guitar/bass and since the moment I made the purchase I have not regretted it. I use the plugin on GNU/Linux and I've never had any problems before. I recently switched to Ubuntu Studio 21.04 (previously used version 20.04 of the same flavor) and, inside Ardour (version 6.6.0), it doesn't work properly. I managed to install via terminal and still gave an error when finished. Whenever I try to change the preset it everything froze and the DAW crash. Could any of you help me solve this problem? In the images: installer, how the plugin behaves inside Ardour and terminal.

    Screenshot_20210424_182655.png
    Screenshot_20210424_182816.png
    Screenshot_20210425_114401.png

    Thanks!

    Edit:
    As standalone It woks beautifully.

    Screenshot_20210425_155536.png
     
    Last edited: Apr 25, 2021
  2. xylph

    xylph New Member

    Hi,
    Go in /usr/lib/ and try to remove the vst3/
    I recovered the preset in Ardour
     
  3. Elson Fernandes

    Elson Fernandes New Member

    Hi, xylph! Your suggestion didn't work for me. I was trying to use Guitarix in the meanwhile, but it's not as good as ToneLib. For a moment, it worked, but Ardour stopped and when it came back it didn't work anymore. If you have another suggestion, I’ll try. Thanks!
     
  4. Vasilis Lambrou

    Vasilis Lambrou New Member

    Hello all!
    I'm having the same problem and from what I've found it has to do with the VST3 version of the plugin. I unchecked the following option
    "conceal VST2 Plugin if matching VST3 exists" under plugin options in preferences.

    After than I can select the VST2 from the plugin menu and for the most of the times it works as it should. But, when I'm opening an older project containing Tonelib GFX as a plugin, Ardour instantly crashes.
     

    Attached Files:

    Elson Fernandes likes this.
  5. Elson Fernandes

    Elson Fernandes New Member

    DUUUUUUUUDE!!!! IT WORKED!! Thank's a lot man! Holy s*&t! Before only the VST3 version appeared. The images prove it! God bless you and your entire family!

    01-RESOLUTION-Screenshot_20210609_222141.png
    02-RESOLUTION-Screenshot_20210609_222234.png
    03-RESOLUTION-Screenshot_20210609_222516.png
     
  6. Vasilis Lambrou

    Vasilis Lambrou New Member

    Glad to be such a help my friend! All the best!
     
    Elson Fernandes likes this.
  7. ab12cd34

    ab12cd34 New Member

    Still crashes for me on Linux with Ardour 6.9 even with using the VST2 - both tonelib-gfx and tonelib-metal have this issue. That plus the presets are busted ion Ardour with the VST3. It's like the devs never even tried it.
     
  8. Vasilis Lambrou

    Vasilis Lambrou New Member

    I can also confirm that the bug remains with the latest update. Really disappointing.
     
  9. thefunnyside

    thefunnyside New Member

    There is no ticket tracker and there's no way to get in touch with them. We dont't even know if they even read the forum.
     
  10. Vasilis Lambrou

    Vasilis Lambrou New Member

    They only have that one contact form which probably sends our messages to a galaxy far away. I have sent them 3 messages(or more, I cannot recall exactly), asking them an older .deb file so that I can reopen my Ardour projects. They NEVER ANSWERED ANYTHING! I have paid this piece of software but the support is close to nothing.
    I had really high hopes on Tonelib GFX when I first discovered it, and thought that to support a smaller company which seemed to care for the Linux side of thing was a must-do. Unfortunately they just redesigned their website and don't seem to have nor the means or the will to sustain properly this promising product.
    I feel kinda disrespected, it would be appreciated just to say "hey man, we cannot do anything on this because of funds or personnel or whatever". And now I see that "whole new product" - Tonelib Metal. Which seems exactly the same as GFX just with different presets. Tested it with exactly the same results.
    Sorry for my ranting but I had to let it out.
     
  11. thefunnyside

    thefunnyside New Member

    Unfortunately, this is what we get with proprietary software. I'd say Guitarix works pretty well but its UI is nonetheless not as straightforward as Tonelib GFX.
     
  12. xenobarbital

    xenobarbital New Member

    I have the same problem with Ardour on Manjaro. Standalone versions of both GFX and Metal work fine, but VST2 and 3 plugins of both packages crash the DAW the moment I try to do pretty much anything. There were some complaints here about splitting the amp sims into two separate binaries. I don't mind that, and I don't mind paying extra $50 for high gain amp sims. But there's no way in hell I'm purchasing Tonelib Metal before you guys (I'm talking to you dev team) fix this damn problem. And it's not like I don't have any alternative. Guitarix and AudioAssault plugins work just fine in Ardour.
     
  13. ospi

    ospi New Member

    Adding or selecting a preset with "Guitar IRs Cab" or "IR Processor" plugins causes Ardour 6.9.0 and Qtractor 0.9.20-1 to crash
    while standalone, hosting the plugin in Carla 2.4.1 and Reaper 6.4 work fine.

    Bug is also tracked at https://tracker.ardour.org/view.php?id=8814 which includes some debug output.

    edit : Workarounds i've used until this is resolved. Remove the tail end of signal chain (usually IR and some reverb) and use "ir.lv2" plugin (found at ubuntu studio repos at least) + Dragonfly echo in Ardour. Or replace the IR with Splitter and couple of Cab sims.
     
    Last edited: Feb 12, 2022
  14. Admin

    Admin Administrator Staff Member

    Hey guys, just a quick note here.

    We have been aware of this problem with TL GFX not working correctly in Ardour. Our team has been trying for a long time to determine the cause of this problem and to fix it by ensuring stable work of VST and VST3 plug-ins in this DAW.
    And in the latest version we have succeeded after all.

    In the latest builds of TL GFX and TL Metal this problem should be fixed, and both of these products should work stable in Ardour.
    Please re-download and reinstall the latest version of our products on the download page or via the following direct links:


    https://www.tonelib.net/download/ToneLib-GFX-amd64.deb

    https://www.tonelib.net/download/ToneLib-Metal-amd64.deb



    Please accept our sincere apologies for having to deal with such inconveniences for a long time.


    Best regards,
    ToneLib Team
     
    Last edited: Feb 15, 2022
    thefunnyside likes this.
  15. ospi

    ospi New Member

    Confirming Tonelib GFX using IRs now works with Ardour 6.9.0 and Qtractor 0.9.20-1. Convoluted thanks to devs! :D
     
  16. thefunnyside

    thefunnyside New Member

    Very good news. Thanks!
    May I suggest that setting up a ticket tracker would be much appreciated for dealing with issues.

    Cheers,
     
    Vasilis Lambrou likes this.
  17. Vasilis Lambrou

    Vasilis Lambrou New Member

    I second that, it would be very helpful. Also helpful would be an archive or something, so if anything happens in an update you can always use an earlier version.
     
  18. ab12cd34

    ab12cd34 New Member

    I've downloaded and installed the new version of ToneLib GFX. It's moderately more stable, but still crashes in a similar fashion. I'm running ardour 6.9. As before there is very little indication of what went wrong. It happens with the VST3 version of the plugin. Ardour suddenly closes when it crashes. The environment is an updated AvLinux.

    Notable behaviours, when the VST3 opens, the preset menu's doesn't appear on the left side (ToneLib metal DOES show the preset menu). The only way to access presets is by choosing an empty preset slot to make a new preset and then using the up and down arrows from the icon just above the preset name etc area to select a different preset.

    The VST is slightly more stable than the previous version, but still causes crashes. Ardour is very stable when the preset is removed.

    If there is specific info that needs to be collected to diagnose, I'm happy to do so. Devs just say what you need.
     
  19. xylph

    xylph New Member

    Hi don't use the vst3 version. (you can remove the plugin in /usr/lib/vst3 or configure ardour to not use vst3)
    The new version 02/14/2022 does not crash and it seems ok. I've install tonelib-metal only in vst2 and seems stable.
     
  20. thefunnyside

    thefunnyside New Member

    Tonelib GFX advertises it supports VST3 so it has to be fixed if its broken.