ToneLib-GFX Linux Error

Discussion in 'Bug Reports' started by Marauder Music, Nov 28, 2021.

  1. Marauder Music

    Marauder Music New Member


    Small issue to report here.
    -Upgraded from Ubuntu Studio 64 LTS 20.04 to the Ubuntu Studio 64 21.10 recently.
    -Previously ToneLib GFX installed on the Ubuntu Studio 64 LTS version prior to the 4.7.0 release. That install via the .deb file with no issues.

    -For this new Ubuntu Studio 64 21.10 install with ToneLib 4.7.0 when running the .deb install got a box with an Error: Missing Dependencies no details were provided.
    -Entered terminal mode and ran the dpkg -i and the file name to force an install. It installed grabbing some packages but reported it was still missing some files (sorry I did no capture a list).
    -It still runs and seems to work OK standalone and in Linux Native Reaper sessions.
    -Only been a day and no request to register it yet, maybe that times out after a few days?

    -Noticed I had an open notification for language package install not complete. it was stuck at 15%. Told it to finish install and it failed and reported some error with ToneLib. So there is a hint on the issue, something with language dependencies.

    If you need more data please ask and I will try to rerun the install and grab the data.
    TOneLib on Liniux has been incredible and want to see it continue!!

    Last edited: Nov 28, 2021
  2. laptwan

    laptwan New Member

    any solutions thus far? I just updated to latest Ubuntu Studio and cannot install any of the tonelib software as well. Issues are missing dependencies
  3. Marauder Music

    Marauder Music New Member

    This became a non issue as I was able to install ToneLib with a later release.
    I use another VST amp sim these days in Reaper.
    I still use ToneLib stand alone for practice (metronome)
    Decided to go back and use ToneLib for a project in Reaper Native today and now it has graphics issues. Both GFX and Metal.
  4. Marauder Music

    Marauder Music New Member

    I just installed the latest Reaper and tried to install ToneLib Metal and got the attached message.Wanted to A/B ToneLib against another Linux plug in VST and currently as an all stop. Screenshot_20221106_132817.png
  5. Marauder Music

    Marauder Music New Member

    Solved this from a Youtube video, scroll through the video to get to the commands needed.

    The short answer is open terminal from the folder your download is in and enter
    sudo dpkg -i ToneLib-Metal-amd64.deb

    or the name of your file (gfx, etc)
    Hit enter and your password and it will go.

    Found this before but forgot all about it.