Tonelib GFX plugin crashes on certain presets under Linux

Discussion in 'Bug Reports' started by lorubenet, Apr 3, 2021.

  1. lorubenet

    lorubenet New Member

    Dear support,

    First of all, thanks for enabling a Linux version of your guitar effects software. That, and the sound it has were the reasons that made me purchase it.

    The linux version of the plugin however crashes when certain presets are loaded. A preset that crashes is for instance the "02D Comfortably Torpid".
    Carla can handle the problem in the "carla-git" version (namely it works), but not the default released version (luckily the plugin crashes but carla survives). At crash time it logs:

    Carla assertion failure: "unlocked" in file ../utils/CarlaSemUtils.hpp, line 182
    waitForClient(process) timed out

    Ardour6 crashes along with the plugin saying in the command line:
    Emulate VST Bypass Port for ToneLib-GFX
    dispatch_x_events: ConfigureNotify cfg: (1200 656) plugin: (1200 656)
    The Tonelib GFX application works fine without problems on those presets.

    Please let me know if I can help dig out this problem with more information/logs.
    your-highness likes this.
  2. your-highness

    your-highness New Member


    In Ubuntu Studio 20.04 (X-fce WM; 5.4.0-72-lowlatency kernel) I am having the same issues in the standalone ToneLib client with some presets (e.g. "[11C] High gain lead"):

    The whole desktop freezes for 5 - 10 seconds and starts running again for 5 secs until going back to freeze (in repeat). When switching to another (e.g. empty) preset not freeze is happening.

    ToneLib Amp Emulation Sound works while freezing, i.e. I can play. The ToneLib-GFX process is in "S" state while freezing. ToneLib does not produce any log to the terminal which is indicative.

    I would be very happy if anyone could shed light on this and how to fix that issue.

    Last edited: Apr 27, 2021
  3. xylph

    xylph New Member


    I'm using Fedora and I have the same issue.
    Tonelib GFX works fine in standalone, but in ardour6, if I choose some preset, or for example, if I choose the "Bass IRs Cab", it crash
    Unknown error...
    terminate called after throwing an instance of 'Jack::JackTemporaryException'
    I love this vst, it has a great sound quality. But I need a full fonctional application. I wanted to purchase it, but I 'm gonna wait before it's resolved.
    your-highness likes this.
  4. your-highness

    your-highness New Member

    Actually I assume the error described here is GTK related because the sound still works.

    I recently bought ToneLib GFX because while initial testing in early April I did not experience problems. Might it be related to the current version? Is it possible to download older versions as deb?
  5. xylph

    xylph New Member

    I try again tonelib gfx this day and I see: some presets crash, but if you run tonelib gfx vst with carla, it doesn't crash.
    I don't know why it works with carla but not with ardour
    your-highness likes this.
  6. your-highness

    your-highness New Member

  7. xylph

    xylph New Member

    Yes, I work in 44100 too and I get crashes.
  8. xylph

    xylph New Member

    Up, there is the new version 4.7.0 and it crashes again in the same configuration like the last version before
  9. Vasilis Lambrou

    Vasilis Lambrou New Member

    Same here guys, on Manjaro with tonelib 4.7.0 and Ardour 6.9-1.
    Tried it with Reaper and had no crashes or whatever, selecting all different presets.
    Also tried with Ardour 5xsomething(a lot older) on a live-usb of Pop!_OS! 20.04 LTS and it crashed again following the same pattern(applying various presets).
    Lastly I executed it on Manjaro with gdb(Gnu Debugger) and got the following error message(when it crashed):

    Thread 132 "Pool" received signal SIGSEGV, Segmentation fault.
    [Switching to Thread 0x7fff0dffb640 (LWP 18761)]
    0x00007fff5f59a89d in ?? () from /usr/lib/vst/

    It's very annoying...hopefully there is a miraculous update on the way
  10. OaaH

    OaaH New Member

    Same problem here, I use arch linux, and it makes ardour crash when landing on the 'wrong' presets. It forces me to use it outside ardour, and I would be really happy to see it resolved.
    Vasilis Lambrou likes this.
  11. Vasilis Lambrou

    Vasilis Lambrou New Member

    Is there a way to get an older deb version of tonelib? An archive or something would be great, to test different versions. I've emailed them asking about it, but got no answer.
  12. Martin Vlk

    Martin Vlk New Member

    Yeah, I'd written and got no answer either...
  13. OaaH

    OaaH New Member

    I have checked the presets who crashed ardour, and I have found that the common effect in them was "guitar IRs Cab". After a check I saw that both "guitar IRs Cab" and "IR processor" crashes arour. The "Cab Sim" works alright, and I assume that he doesn't use IR and just applies frequency filter.
    Maybe it is a bug in ardour? I have tried to run tonelib from Carla and it went ok. I also tried to load carla as an ardour plugin, and then load tonelib from carla - and the result was another glorious crash. I tired to find information about it from the ardour side and had no luck. maybe ardour is having trouble when VSTs try to load impulse response files? does someone have any other VST IR convolver to try on it?

    I tried the IRs from different sample rates (96, 48 and kk.1Khz) and no dice. I have also tried both the LXVST and the VST3 versions of tonelib, and it crashed on both.
  14. Vasilis Lambrou

    Vasilis Lambrou New Member

    I can confirm that, it seems that the issue narrows on these particular effects. I executed the standalone Tonelib-GFX and removed them from all the presets.
    After that when opening it as an Ardour Plugin I can move through different presets without any crash.
  15. WojtekS

    WojtekS New Member

    I can confirm this. Last version working well is 4.5.2, newer are crashing.